Commandes CISCO

  1.  Entrer dans le mode d'exécution privilège
    Switch> enable


    2. Entrer dans le mode de configuration
    Switch# configure terminal

    3. Entrer dans le mode de configuration des interfaces
    Switch(config)# interface GigabitEthernet 0/1

    4. Entrer dans le mode de configuration d'une ligne
    Switch(config)# line 0

    5. Revenir en arrière
    Switch(config-line)# exit

    6. Quitter le monde de configuration
    Switch(config-line)# end

    2- Les fichiers de configuration
    1. Visualiser le fichier de configuration en cours d'exécution
    Switch# show running-config

    2. Visualiser le fichier de configuration au démarrage
    Switch# show startup-config

    3. Enregistrer la configuration encours pour l'utiliser au démarrage
    Switch# copy running-config startup-config
    Ou autre possibilité
    Switch# write


    4. Supprimer un fichier de configuration 
    Switch# erase stratup-config

    3- Configuration générale
    1. Configuration du nom d'un switch
    Switch(config)# hostname newhostname

    Newhostname(config)#
    2. Configuration de la passerelle par défaut du switch
    Switch(config)# ip default-gateway 192.168.1.254

    4- Configuration d’interface
    1. Visualiser la configuration des interfaces
    Switch# show interfaces

    2. Entrer dans le mode de configuration d'une interface
    Switch(config)# interface FastEthernet 0/1


    3. Entrer dans le mode de configuration de plusieurs interfaces
    Switch(config)# interface range FastEthernet 0/1 - 20


    4. Activer une interface
    Switch(config-if)# no shutdown

    5. Désactiver une interface
    Switch(config-if)# shutdown

    6. Configurer l'appartenance d'une interface sur un seul VLAN
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport access vlan 2

    7. Configurer l'appartenance d'une interface sur plusieurs VLAN
    Switch(config-if)# switchport mode trunk


    7.1. Configurer les VLAN autoriser sur cette interface 
    Switch(config-if)# switchport trunk allowed vlan add 2, 3, 10

    7.2. Configurer les VLAN interdit sur cette interface
    Switch(config-if)# switchport trunk allowed vlan remove 3

    7.3. Annuler le filtrage
    Switch(config-if)# no switchport trunk allowed vlan

    8. Configurer le protocole d'encapsulation d'une interface
    Switch(config-if)# switchport trunk encapsulation dot1q

    9. Configurer de la vitesse d'une interface
    Switch(config-if)# speed 10
    Switch(config-if)# duplex half

    10.Activer la configuration automatique de la vitesse d'une interface
    Switch(config-if)# duplex auto
    Switch(config-if)# speed auto

    11.Ajouter une description sur une interface
    Switch(config-if)# description votre_discription_ici

    5- Configuration VLAN
    1. Passer en mode de configuration d'un VLAN
    Switch(config)# vlan 2


    2. Suppression d'un VLAN
    Switch(config)# no vlan 2

    3. Passer en mode de configuration de l'interface du VLAN
    Switch(config)# interface vlan 2

    4. Définir une adresse IP statique sur l'interface d'un VLAN
    Switch(config-if)# ip address 192.168.1.200 255.255.255.0

    5. Définir une adresse IP dynamique sur l'interface d'un VLAN
    Switch(config-if)# ip address dhcp

    6. Activer l'interface d'un VLAN
    Switch(config-if)# no shutdown

    7. Désactiver l'interface d'un VALN
    Switch(config-if)# shutdown

    6- Sécurisation
    1. Définir un mot de passe sur le mode d'exécution privilège
    Switch(config)# enable secret password

    2. Configurer un mot de passe sur la première ligne du terminal
    Switch(config)# line console 0
    Switch(config-line)# password password
    Switch(config-line)# login

    3. Configurer un mot de passe sur le terminal virtuel
    Switch(config)# line vty 0 15
    Switch(config-line)# password password
    Switch(config-line)# login

    4. Configurer la connexion SSH
    Switch(config)# line vty 0 15
    Switch(config-line)# login local
    Switch(config-line)# transport input ssh
    Switch(config-line)# exit
    Switch(config)# username name password pwd 
    Switch(config)# ip domain-name exemple.com
    Switch(config)# crypto key generate rsa

    5. Configurer la sécurisation d'une interface
    Switch(config)# interface FastEthernet 0/1
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport port-sécurity maximum nombre

    5.1. Bloquer les trames sans message d'avertissement
    Switch(config-if)# switchport port-sécurity violation protect


    5.2. Bloquer les trames avec message d'avertissement
    Switch(config-if)# switchport port-sécurity violation restrict

    5.3. Désactiver l'intergace, bloquer l'interface et message d'avertissement
    Switch(config-if)# switchport port-sécurity violation shutdown

    5.4. Configurer manuellement les adresses MAC autorisée
    Switch(config-if)# switchport port-sécurity mac-address 000C.CF66.93AD

    5.5. Configurer automatique les adresses MAC autorisée
    Switch(config-if)# switchport port-sécurity mac-address sticky

    6. Chiffrer les mots de passe
    Switch# configure terminal
    Switch(config)# service password-encryption


    7. Ajouter un message d’avertissement
    Switch# configure terminal
    Switch(config)# banner motd #Authorized Access Only#


Revision #3
Created 8 November 2022 14:11:02 by Admin
Updated 8 November 2022 14:28:07 by Admin